Jump to content

Search the Community

Showing results for tags 'internal disc brake'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Site Help
    • Site Help
  • LCUSA Members Area
    • Club Management
    • The Specialist and Gazette
    • Classifieds-Members Only
    • Member News
  • Public Area
    • Welcome to LCUSA & Club News
    • Membership Questions
    • Chit Chat
    • Technical Advice
    • Product Reviews & Installations
    • Jamboree Information
    • What's happening
    • Show Us Your Lambrettas
    • LCUSA Facebook Group
    • LCUSA Facebook Classifieds

Product Groups

  • Membership and Jamboree Registration
    • LCUSA Membership
    • Lambretta Jamboree Registration

Categories

  • Model Information
    • Italian Lambrettas
    • Spanish Lambrettas
    • Indian Lambrettas
    • South American Lambrettas
    • French, German and Tawainese Lambrettas
  • Tech Tips and How-to's
    • Maintenance
    • Performance
    • Tips and Tricks

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Currently Owned Lambrettas

Found 1 result

  1. Ok, I think I figured out what’s up with my rapid loss of brake lever. After 400 miles on a hub/brake rebuild it looks like The grub screw for the static pad is working it’s way thru the back of the steel backing plate, not the compound that rides against the rotor. Am I missing something here or maybe the steel backing to soft, or the screw to rounded off. I cant remember where I got this set of pads, but i have a new set of Newfren ones here to try instead. Also get a new adjusting screw. the internal disc works really well when adjusted up properly. Any body else running into this sort of black magic?
×
×
  • Create New...