Jump to content
strangewhispering

Is this why my bike has been eating k/s seals? YOU Decide!

Recommended Posts

My series 3 large block motor eats k/s seals.  The seals tear along the seal surface that sits on the k/s shaft.  Am I correct in thinking that the scuff/polish marks on the shaft and bushings (see photos) are the likely culprits and I should probably swap out both of the bushings and the shaft as well?  Or can I get away with just swapping the bushings and leaving the shaft?

Thanks,

-Scott

IMG_1777.JPG

IMG_1779.JPG

IMG_1780.JPG

IMG_1781.JPG

IMG_1782.JPG

IMG_1783.JPG

IMG_1786.JPG

IMG_1789.JPG

IMG_1790.JPG

IMG_1792.JPG

Share this post


Link to post
Share on other sites

Strange there is no replies to this. It appears the kickstart shaft is bent. It’s not a common fault (unlike snapping), and I’ve only seen it happen once before. 

Share this post


Link to post
Share on other sites

Yep, I'd chuck it and replace the whole shootn' match. Then you'll know what you have and won't have to worry about taking the whole thing apart just because it's still failing after the repair.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...